Empty rover results...

Report bugs here. If you're not sure of the cause, use the troubleshooting forum instead.
Post Reply
BTGbullseye
10+ Posts
10+ Posts
Posts: 11
Joined: Wed Feb 18, 2015 2:28 am
Sex: Male

Empty rover results...

Post by BTGbullseye » Sat Mar 14, 2015 1:08 pm

TorrentRover v0.23.1 beta (non-portable)
Windows 7 Ultimate x64

To start, searching for "the 100 s02e16 eztv" has 0 results... Searching instead for "the 100 s02e15 eztv" provides a ton of results, including 1 for episode 16.

After restarting, the first search only shows 2 results, (both for episode 15) and the second shows 3 results. (all three for episode 16)

This happened whether I chose to load the last used rovers, or if I made new ones.

User avatar
John
Owner
Owner
Posts: 169
Joined: Wed Feb 12, 2014 9:56 am
Sex: Male
Location: Warsaw, Ohio
Contact:

Re: Empty rover results...

Post by John » Sun Mar 15, 2015 9:33 pm

I got several correct results for "the 100 s02e16 eztv", but I also got some results with "s02e15" in the title too. This is the search site returning those results. If you're searching for a weekly show, use the weekly option in Add Rover window. Using the weekly Rover option will make it smart enough to filter other season/episode code. If you just use the quick search, it'll just show whatever the search site returns, which may or may not be as good.

I will try to make TorrentRover smarter even in quick search mode. In the future, if it detects a season/episode code, I'll remove results that don't match that code.
A good programmer is someone who always looks both ways before crossing a one-way street. - Doug Linder

TorrentRover exists on donations... Please donate!
TorrentRover on Facebook
TorrentRover on Twitter
TorrentRover on YouTube

User avatar
John
Owner
Owner
Posts: 169
Joined: Wed Feb 12, 2014 9:56 am
Sex: Male
Location: Warsaw, Ohio
Contact:

Re: Empty rover results...

Post by John » Sun Mar 15, 2015 10:48 pm

Ok, I made it smarter for you. Now if it detects a season/episode code in the search text, it'll only show results that do NOT contain another season/episode code. Notice that it still shows results with no season/episode code at all.

Here is what it did before the fix:
before.png
Before...
before.png (164.55 KiB) Viewed 3212 times
Here is what it does after the fix:
after.png
After...
after.png (84.02 KiB) Viewed 3212 times
This change will be in the next release (0.23.2).
A good programmer is someone who always looks both ways before crossing a one-way street. - Doug Linder

TorrentRover exists on donations... Please donate!
TorrentRover on Facebook
TorrentRover on Twitter
TorrentRover on YouTube

BTGbullseye
10+ Posts
10+ Posts
Posts: 11
Joined: Wed Feb 18, 2015 2:28 am
Sex: Male

Re: Empty rover results...

Post by BTGbullseye » Wed Mar 18, 2015 8:38 am

Awesome, thanks. :)

Though the problem I was reporting was that it was giving wrong results until I restarted the program, not that it was giving the wrong episode code results. (the searches were the same, but the results were different ONLY after restarting)

User avatar
John
Owner
Owner
Posts: 169
Joined: Wed Feb 12, 2014 9:56 am
Sex: Male
Location: Warsaw, Ohio
Contact:

Re: Empty rover results...

Post by John » Wed Mar 18, 2015 8:46 am

Could be a timing or caching issue??? I assumed it was something in the code.

At least now you won't get the wrong episodes when you search for shows.
A good programmer is someone who always looks both ways before crossing a one-way street. - Doug Linder

TorrentRover exists on donations... Please donate!
TorrentRover on Facebook
TorrentRover on Twitter
TorrentRover on YouTube

BTGbullseye
10+ Posts
10+ Posts
Posts: 11
Joined: Wed Feb 18, 2015 2:28 am
Sex: Male

Re: Empty rover results...

Post by BTGbullseye » Wed Mar 18, 2015 8:40 pm

At least. lol

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest