bug?

Report bugs here. If you're not sure of the cause, use the troubleshooting forum instead.

bug?

Postby bobbfrommn » Thu Oct 23, 2014 8:22 am

Not sure if this is a bug or not but...
When I go to edit and existing rover that is a TV show it doesn't let me put a value in the Start With box. It's not a huge deal but I thought if it's a bug you'd want to know.

{Name}
{TorrentRover Version} 0.22.9
{OS/Version} Win 7 64
bobbfrommn
New User
New User
 
Posts: 5
Joined: Thu Oct 23, 2014 8:05 am

Re: bug?

Postby John » Thu Oct 23, 2014 9:12 am

Single (once) Rovers are pretty simple, but when you get into daily or weekly Rovers, there's a bit more going on.

Let me try to explain.

The architecture of the app is "Rover contains Search(es), Search(es) contain Torrents". When you do a single (once) search, you don't even see the Search part because there's only one and it's the same search text as what's on the Rover, so the search is completely hidden. But when you do a daily or weekly search, the Rover can contain multiple Searches (eg. S01E01, S01E02, etc...). The "Starts With" allows you to tell the Rover you're creating where to start searching (eg. Season 10 Episode 1). If you edit a Rover, however, the searches are already added, and you can't pick a new starting point. That's why those boxes are greyed out.

If you want to add more Searches to a Rover, select the Rover, and you can use the button toolbar in the middle of the screen to get previous season, previous episode, next episode, and next season. It'll add whatever comes before or after based on the currently selected Search.

NOTE: The middle toolbar will only be visible when you select a daily or weekly Rover. If you select a single (once) Rover, it's hidden because it doesn't do anything.

Back to your question about the "Starts With" boxes. Would it be less confusing if they were hidden in the case of a Rover edit? I can certainly hide them...
A good programmer is someone who always looks both ways before crossing a one-way street. - Doug Linder

TorrentRover exists on donations... Please donate!
TorrentRover on Facebook
TorrentRover on Twitter
TorrentRover on YouTube
User avatar
John
Owner
Owner
 
Posts: 146
Joined: Wed Feb 12, 2014 9:56 am
Location: Warsaw, Ohio

Re: bug?

Postby john5566 » Fri Oct 31, 2014 5:35 am

Here are the rules for all forums.

1. DO NOT post any content which violates any copyright law, especially those of the United States. This includes not suggesting someone else break the law.
2. You have complete freedom of speech, but if you choose to be belligerent, be prepared to be responded to in kind.
3. If you have any questions about these rules, you can ask in the Help forums.
john5566
New User
New User
 
Posts: 1
Joined: Fri Oct 31, 2014 4:03 am

Re: bug?

Postby John » Fri Oct 31, 2014 8:38 am

I''m confused. Are you suggesting that someone violated these rules?

Do you have a question about these rules? If so, please start your own thread rather than posting a new question to an existing thread.
A good programmer is someone who always looks both ways before crossing a one-way street. - Doug Linder

TorrentRover exists on donations... Please donate!
TorrentRover on Facebook
TorrentRover on Twitter
TorrentRover on YouTube
User avatar
John
Owner
Owner
 
Posts: 146
Joined: Wed Feb 12, 2014 9:56 am
Location: Warsaw, Ohio


Return to Report a Bug

Who is online

Users browsing this forum: No registered users and 1 guest